VirtualBox auf 16 Bit Farbtiefe einstellen

    VirtualBox auf 16 Bit Farbtiefe einstellen

    Hallo,

    ich habe mir einen Laptop gekauft – leider mit Windows 8.....Da hier Dual Boot nicht möglich ist habe ich mir die
    VirtualBox (oracle/sun) heruntergeladen um mehrere Betriebssysteme installieren (XP/Win 7) zu können.
    Ich benötige für ein Spiel 16 Bit Farbtiefe (Siedler 4 für den Editor- ich erstelle Spiele damit).
    Egal ob Win7 oder XP die VirtualBox schreibt mir immer folgende Fehlermeldung:

    ““Das Fenster der virtuellen Maschine ist optimiert für

    eine Anzeige im 32 Bit Farbmodus, der aktuelle Modus des virtuellen Bildschirms
    ist aber auf 16 Bit gesetzt .Bitte ändern.““


    Wenn ich den Siedler 4 Editor aufrufe meldet der
    Farbtiefe 16 Bit muss eingestellt sein.


    Anscheinend ist es möglich 16 Bit Farbtiefe in der VirtualBox einzustellen.

    Siehe Link: linuxundich.de/de/software/bel…r-eine-virtualbox-setzen/

    Ich habe VBoxManage aufgerufen – komme aber nicht weiter.Ich kenne mich im Bios auch nicht aus.
    Die - Gästeerweiterung - habe ich auch installiert.
    Könnte Ihr mir bitte helfen.Ich kann den Laptop wegwerfen
    – da ich mir den nur wegen dem S4 Editor und lokaler Unabhängigkeit gekauft
    habe.


    Vielen Dank

    Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von „nobby91“ ()

    Hallo und willkommen im Forum!

    Die Farbtiefe, in der ein Betriebssystem arbeitet, wird i. d. R. immer im entsprechenden Betriebssystem eingestellt. VirtualBox hat da eigentlich kein Mitspracherecht. Die Gasterweiterung braucht man u. U., damit VirtualBox das erkennt, mehr nicht.

    Für Windows 7 sieht das so aus:

    Rechtsklick auf Desktop -> Bildschirmauflösung ändern -> Erweiterte Einstellungen -> Reiter [Monitor] -> Farbtiefe ...




    Was Windows 8 angeht, so müsste das eigentlich genau so gehen. Habe gerade kein Windows 8 zur Verfügung, aber sobald ich heute Abend bzw. Morgen dran komme, kann ich gerne nachsehen.
    Hallo Max,


    natürlich habe ich die 16 Bit Farbtiefe unter W 7 eingestellt.Unter W 8 64 Bit ist nur 32 Bit als niedrigste Farbtiefe einstellbar..

    Das W 7 läuft ja in der Virtualbox und ist auf 16 Bit eingestellt , aber die Virualbox auf 32 Bit – deshalb bringt die VB immer diese Fehlermeldung.Also muss ich die Virtualbox auf 16 Bit Farbtiefe einstellen damit der Siedler 4 Editor arbeiten kann.

    In dem Link ist es vom Verfasser gut beschrieben wie man die Auflösung und Farbtiefe bei der Virtualbox ändern kann.
    Es geht über VBoxManage – nur ich komme da nicht weiter und weiß nicht wie ich es aufrufen und ändern soll.

    Beschreibung im Link:
    -------------------------------------------
    Bildschirmauflösung setzen:

    Erst einmal sollte man seine VM starten und den Namen der
    VirtualBox im Kopf behalten. Wer sich diese Info nicht so lange merken kann,
    der bekommt über VBoxManage eine Liste mit allen derzeit aktiven virtuellen
    Maschinen anzeigen lassen…

    $ VBoxManage list runningvms

    "Windows XP" {88825782-72a0-41f5-98eb-f58b19ab5d1e}
    "Ubuntu Natty"{a22339bf-81e9-4c0e-9f99-f912eacba713}


    Danach ist der Rest nur noch ein Kinderspiel. Über…
    $ VBoxManage controlvm "Windows XP" setvideomodehint 1440 900 32

    …gibt man die gewünschte Auflösung und Farbtiefe ein
    --------------------------------------------
    Und hier müsste ich vermutlich 16 anstatt 32 eintragen – aber soweit komme ich gar
    nicht…


    Der wichtige Link (Beliebige Auflösungen für eine VirtualBox setzen)

    linuxundich.de/de/software/bel…r-eine-virtualbox-setzen/

    Bitte den Link lesen – Danke.
    Ach, jetzt komme ich mit :rolleyes: ...

    VBoxManage.exe befindet sich im Installationsverzeichnis der VirtualBox. Diese Anwendung kann aber nur in Verbindung mit Parametern funktionieren. Im Fall von Windows muss das mit der Eingabeaufforderung gemacht werden.

    Kleines Beispiel: Angenommen, der Pfad zur VBoxManage.exe würde C:\Programme\VirtualBox\VBoxManage.exe lauten, dann müsste der Befehl in der CMD um bspw. alle virtuellen Betriebssysteme auflisten zu lassen folgendermaßen lauten:

    Quellcode

    1. C:\Programme\VirtualBox\VBoxManage.exe list hdds


    Das musste jetzt nur auf Deinen Fall übertragen. Natürlich könnte man noch mit cd-Befehlen in den Installationsordner springen (dann müsste man nur VBoxManage.exe <Parameter> anstatt den kompletten Pfad angeben), oder eine Variable mit dem Pfad belegen, aber wenn man das nur einmal braucht lohnt sich da der Aufwand mit Letzterem nicht wirklich ...
    Hallo,

    bei mir ist der Pfad - C:\Programme\Oracle\VirtualBox\VBoxManage.exe list hdds

    Ich habe die cmd aufgerufen und den Pfad eingegeben - ( brachte eine Fehlermeldung – not found.

    Ich habe im Installationsverzeichnis der VBox nachgeschaut und VBoxManage gefunden – Typ: Anwendung 944 KB.Eine EXE habe ich
    nicht gefunden ?????

    Wenn ich einen Doppelklick darauf mache erscheint kurz
    ein Biosfenster – allerdings nur eine Sekunde – danach ist das Fenster wieder weg.

    Und welchen Befehl ich für die Farbtiefe eingeben müsste ist mir auch nicht bekannt.


    Ist jemand bei Oracle angemeldet ? Um direkt nachzufragen.Bei mir funktioniert der Verifizierungslink in der e-mail nicht – error.

    nobby91 schrieb:

    Wenn ich einen Doppelklick darauf mache erscheint kurz
    ein Biosfenster – allerdings nur eine Sekunde – danach ist das Fenster wieder weg.

    Das ist richtig. Soll auch so sein. Das Programm funktioniert auch nur mit Parametern.

    Vermutlich hast Du die Dateiendungen ausgeblendet, deswegen siehst Du das *.exe nicht. Drücke einfach mal die SHIFT-Taste, während Du auf VBoxManage einen Rechtsklick machst. Da müsste nun der Punkt "Als Pfad kopieren..." auftauchen. Den klicken und in bspw. Notepad einfügen, dann haste den ganzen Link.



    Alternativ kannste auch die Eingabeaufforderung in dem Ordner starten (hier gibts das Video dazu ). In dem Fall musst Du nur VBoxManage.exe <Parameter> eingeben. Sollte das auch nicht funktionieren, lasse mal das *.exe weg.

    Der Befehl für die Farbtiefe von 16-Bit bei einer Auflösung von 1440x900 würde folgendermaßen lauten:

    Quellcode

    1. VBoxManage.exe controlvm "<NAME DER VM>" setvideomodehint 1440 900 16

    bzw.

    Quellcode

    1. VBoxManage controlvm "<NAME DER VM>" setvideomodehint 1440 900 16
    Hallo ,

    siehe Anhang.

    Ich habe einiges gelernt - funktioniert aber trotz korrekter Eingabe nicht.Er bringt sofort unter der VM Win 7 wieder die Fehlermeldung - VBox ist auf 32 Bit eingestellt - sie haben 16 Bit Farbtiefe eingestellt - bitte ändern.

    Nobby
    Bilder
    • VBoxManage.jpg

      109,87 kB, 660×662, 7 mal angesehen
    Hallo.

    habe natürlich trotzdem gleich den Siedler Editor getestet - bringt aber gleich - 16 Bit Farbtiefe muss eingestellt sein.
    Das Siedler 4 Spiel läuft auch unter W 8 - aber der Editor (um Spiele zu erstellen ) braucht 16 Bit Farbtiefe - unter W 8 ist nur 32 Bit Farbtiefe einstellbar - zumindest auf meinem Laptop.
    Was OS ist ist weiß ich nicht!
    nobby

    Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von „nobby91“ ()

    Ich habe Dich nicht vergessen, aber momentan habe ich etwas viel um die Ohren. Mit OS (=Operating System) ist das Betriebssystem gemeint. Mir ist da gerade noch was eingefallen: Hast Du den Editor mal mit 256 Farben bzw./inkl. minimaler Auflösung versucht zu starten (siehe Screenshot)? Zu finden sind die Einstellungen bei Rechtsklick über dem Programm -> Eigenschaften -> Einstellungen.
    Bilder
    • einstellungen_application.jpg

      25,35 kB, 334×148, 1 mal angesehen